Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: New guy with a 79

  1. #1
    Join Date
    Jun 2009
    Location
    MN
    Posts
    3

    Question New guy with a 79

    Hi I picked up a 79 scout II last fall and now I'm starting to adress some "issues" with it any advise would be great. The first is that the PO installed a in-line elect. fuel pump worked great for about 50mi now you can make it about 3 maybe 5mi on a good day before it dies. Pulled pump down blew out fuel line going to tank and to carb, filter good, pump works fine on bench with a power probe. Happened again on sunday went under truck and fuel pump is prety warm what do you think, bad pump? The pump that is on it now is rated for 9psi is that ok?

    Second steers REALLY bad. The p-steer res is about 3/4 full but you hear no howling from pump I think the rag joint and u-joints need to be replaced what do you think? steering wheel feels really nice and easy to steer then tightens up then gets better happens both left and right lock to lock. Also wheel will not track back back when you finish your turn I end up chasing the thing down the road any input on these "issues" would be great thanks- Joe

  2. #2
    Join Date
    Apr 2009
    Location
    Houston
    Posts
    95

    Default Would have saved me time

    Quote Originally Posted by Smokin_Joe View Post
    Hi I picked up a 79 scout II last fall and now I'm starting to adress some "issues" with it any advise would be great. The first is that the PO installed a in-line elect. fuel pump worked great for about 50mi now you can make it about 3 maybe 5mi on a good day before it dies. Pulled pump down blew out fuel line going to tank and to carb, filter good, pump works fine on bench with a power probe. Happened again on sunday went under truck and fuel pump is prety warm what do you think, bad pump? The pump that is on it now is rated for 9psi is that ok?

    Second steers REALLY bad. The p-steer res is about 3/4 full but you hear no howling from pump I think the rag joint and u-joints need to be replaced what do you think? steering wheel feels really nice and easy to steer then tightens up then gets better happens both left and right lock to lock. Also wheel will not track back back when you finish your turn I end up chasing the thing down the road any input on these "issues" would be great thanks- Joe
    This would have saved me lot of time. If it has points check the gap there. Mine is also a 79' and according to mreading shouldn't have had points at all but after I replaced nearly everything ignition and fuel pumps and filters this is where the issue was. If the points look burned up make sure there is a ballast or ignition resistor in line with the coil. If of isn't there the higher voltage will fry the points and the coil won't last very long. For fuel make sure the tiny filter in the carb is also replaced. Hope some of this helps.

  3. #3
    Join Date
    Apr 2009
    Location
    Houston
    Posts
    95

    Default

    Definately start with replacing the steering couplet that rubber disc is probably dry rotted accounting for the slop in the turn. As for the rest of the steering issues see if you still have them after this fix. Not returning to zero after a turn may have to do with the axles angle need shims to correct.

  4. #4
    Join Date
    Jun 2009
    Location
    MN
    Posts
    3

    Default thanks

    Thanks for the input will dig deeper this weekend- Joe

  5. #5
    Join Date
    Jun 2009
    Location
    Hurlburt Field, FL
    Posts
    495

    Default

    For the steering, if you're going to replace the rag joint, I'd highly recommend this instead. You won't have nearly as much "play" before the response when you turn the wheel.

    http://www.superscoutspecialists.com...-scout-ii.aspx

  6. #6
    Join Date
    Feb 2009
    Location
    Paso Robles, Ca
    Posts
    63

    Default

    For the steering issues, do you have "play" when you turn the wheel?
    What condition is your rag joint? Are you leaking fluid?

  7. #7
    Join Date
    Feb 2009
    Posts
    14

    Default

    Regarding the steering, has the suspension been modified? i.e. has someone done a spring over on it? If it's SOA and the steering and caster angles were not addressed you may have to do some cutting and welding.

  8. #8
    Join Date
    Jun 2009
    Location
    MN
    Posts
    3

    Default

    No lift looks stock 31" BFG rubber leaks a little PS fluid out pump and presure line at the gear rag joint looks really bad going to start there. Dont think its a caster issue like I said every thing look prety mutch on the up and up.
    Will be in shop this week end diging into it thanks, by the way any one replaced the steer shaft u-joint and rag before looks rusted SOLID and like could be a pain.

  9. #9
    Join Date
    Apr 2009
    Location
    Houston
    Posts
    95

    Default

    Quote Originally Posted by Smokin_Joe View Post
    No lift looks stock 31" BFG rubber leaks a little PS fluid out pump and presure line at the gear rag joint looks really bad going to start there. Dont think its a caster issue like I said every thing look prety mutch on the up and up.
    Will be in shop this week end diging into it thanks, by the way any one replaced the steer shaft u-joint and rag before looks rusted SOLID and like could be a pain.

    I have been prepping mine and keep running out of time. Mine needs a 7/16 12pt socket on the shaft end same on the steering end. You have to separate the shaft from the box. Either pull the box or pull the column. Get some degreaser and clean it up then cover it with WD40. The 12pt is necessary and is a good thing too. I think a 6pt might have just stripped out. Pretty tight. I plan to drop the pitman arm and pull the steering box forward. Then once I have the whole steering coupler in my hand rbuild it with a new dislk from the auto parts store. Costs about6 or 8 bucks and a lot of frustration. Do it with the motor cool and in the morning.

  10. #10
    Join Date
    Jun 2009
    Location
    Hurlburt Field, FL
    Posts
    495

    Default

    Quote Originally Posted by Smokin_Joe View Post
    No lift looks stock 31" BFG rubber leaks a little PS fluid out pump and presure line at the gear rag joint looks really bad going to start there. Dont think its a caster issue like I said every thing look prety mutch on the up and up.
    Will be in shop this week end diging into it thanks, by the way any one replaced the steer shaft u-joint and rag before looks rusted SOLID and like could be a pain.
    I just replaced my rag joint because it decided to fall apart on me. Super Scout Specialists sells one for about 110 bucks, or you can go with a Universal Joint replacement that gives you a tighter response from your steering. It actually costs less, too. But the rag joint was definitely a pain; make sure you use a 12 point socket and not a 6 point, otherwise you'll strip the bolt heads right off.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •