Results 1 to 5 of 5

Thread: Parking Brake Question

  1. #1
    Join Date
    Nov 2009
    Location
    Austin, TX
    Posts
    6

    Default Parking Brake Question

    I am a new Scout owner and need to get my 1976 Scout II inspected. Found out today my parking brake isn't working. I'm assuming its the cable but I have a couple newbie questions. Would most mechanics/brake places be able to just put in a new cable, or do I specifically need to go online and look for a Scout parking brake cable that will fit a 76? If so, is there one just for the rear, front, or both?

  2. #2
    Join Date
    Feb 2009
    Location
    Paso Robles, Ca
    Posts
    63

    Talking

    Installation of the cable is straight forward any brake shop/mechanic would be able to do it, as so could you if you are mechanically inclined.
    Just call one of the Light Line dealers and tell them what part you need. Be it the front half of the cable, back half or both.
    If you have a manual (book, not transmission), it is in there, if you do not have a manual, I would highly suggest getting one.
    I have a 76 as well and I just did this 2 weekends ago. It took me longer to get the rear half of the cable out of the housing (did not disassemble all the way) then to install it.
    I have a certain dealer that I get 90% of my items from as do others. PM me if you need some suggestions.
    Hope this helps.
    Rob

  3. #3
    Join Date
    Nov 2009
    Location
    Austin, TX
    Posts
    6

    Default

    Thanks Rob! I will find a way to PM you (new to the site too). I would definitely appreciate any help or leads. I do have a manual from 76 and did go through it the other night. Got up underneath it yesterday and tried to do some manual tightening. thanks for the help!

  4. #4
    Join Date
    Nov 2009
    Location
    Austin, TX
    Posts
    6

    Default

    Seems as though I'm too much of a newbie to send you a PM. Feel free to shoot me an email at mricks@teksystems.com

  5. #5
    Join Date
    Nov 2009
    Posts
    2

    Default

    mine parking brake has never worked. Thanks for this post

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •